+ Reply to Thread
Results 1 to 4 of 4

Thread: Didn't get the RO stored correctly yet, am I in trouble?

  1. #1
    Join Date
    Feb 2016
    Location
    Mid Michigan
    Posts
    34

    Default Didn't get the RO stored correctly yet, am I in trouble?

    We finished boiling the end of march and got everything cleaned up. I always rinse and wash my RO at the end of each day and flush with distilled water. Was going to wait to add the preservative in it because I was waiting on a new pressure switch and wanted to get everything cleaned. Well life happened and dad and I went to the barn this morning and there the RO sits. No preservative in it and its august. Have I ruined my membrane? What should I do? Add it now and hope it's ok? Thanks for the ideas.
    1986-2002 2x6 Leader evaporator 150 taps drop tubes
    Life happens
    2015 130 taps drop tubes and sap sacs
    2016 225 taps drop tubes and sap sacs
    2017 300+? MicRO single membrane

  2. #2
    Join Date
    Jan 2006
    Location
    Oneida NY
    Posts
    7,732

    Default

    Wash it according to the owner's manual except I'd suggest running it thru 2x the whole process and then after the final permeate rinse, open the vessel and check for off odors. If it smells bad, it might still be salvaged by getting a professional cleaning by Lapierre or any other company that offers the service. Just keep your fingers crossed, talk real nice to the GUY ABOVE and hope for the best.
    Dave Klish about 1320 taps in '15, down to about 700 in '16, up to 850 for 2018?
    2012 Mahindra 36 HP 4x4/ loader/cab/heat/AC:-)
    added a gooseneck equipment trailer and F350 to tow it to haul more sap
    3x8 raised flue evaporator
    250 GPH converted to electric, RO by Ray Gingerich
    6.32 KW solar system, 1.48KW is battery backed up, all net metered
    http://s1041.photobucket.com/albums/...anssugarhouse/
    website: www.cnymaple.com

  3. #3
    Join Date
    Apr 2013
    Location
    Brockport, NY
    Posts
    155

    Default

    It might be ruined. But I'd bet that it isn't. If after your next thorough cleaning it don't work well (bad flow, stinks, etc...) just the MEMBRANE might be shot. They're not terribly expensive, and the rest of the RO should be fine. Not a world ending scenario in my opinion. Maybe not an experience to be repeated, but not disaster. More probable is that it'll be fine after that Flats style thorough cleaning. May be a slight reduced flow but should work ok I'd think. Just my opinion! good luck.

  4. #4
    Join Date
    Mar 2012
    Location
    Walpole, NH
    Posts
    706

    Default

    If you washed when you were done and rinsed it with distilled water, you should be ok. You would have already removed any sugar or bacteria that would make it go bad. Like Maple Flats said wash and rinse good and you should be all set to go.
    Sugaring for 45+ years
    New Sugarhouse 14'x32'
    New to Me Algier 2'x8' wood fired evaporator
    225 Sugar Maples Currently,(105 on 3/16" and 110 on Shurflo 4008 vacuum, 10 gravity), (16,000 before being disabled)
    1947 Farmall H and Wagon with gathering tank
    2012 Kubota with forks to move wood around

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts